Troubleshoot event 1148 with rule sync error

A storage group in Microsoft Exchange Server Information Store contains one or more mailbox stores, depending on the version of Exchange Server you are using and the requirements of the organization. Mailbox stores are the most critical components from a data retention point of view, as they consist of system and user mailboxes. If damaged, mailbox store causes serious problems in the operation of an organization. A mailbox store also consists of two files, namely Priv1.edb and Priv1.stm. Corruption usually affects Priv1.edb file and occurs due to typical reasons such as dirty database shutdown, antivirus software scan, virus infection and network problems. When corrupted, the EDB file on access causes errors under a few event IDs, which can be read from the application event log. Here is one such event ID that generally occurs due to database corruption and requires EDB Recovery solutions.

For example, say you are an Exchange Server administrator with a mailbox store that contains hundreds of user mailboxes. Since the store contains essential information necessary for the uninterrupted operation of the organization, its consistency cannot be compromised. But you note that the event ID listed below is repeatedly seen in the application event log:

Event type: error

Event Source: MSExchangeIS Mailbox Store

Event category: rules

Event ID: 1148

Date: date

Time: time

User: N / A

Computer: computer name

Description:

A line synchronization error has occurred (read verification error).

For more information, see Help and Support Center at go.microsoft.com/fwlink/events.asp.

This error occurs regardless of the fact that all Exchange Server services are running smoothly.

Cause

Exchange database is damaged.

Note: The same error can also occur if the required data is missing.

Solution

The following are possible solutions that can help you repair such database corruption issues:

1. Run ‘Eseutil’ with the ‘/ r’ switch to restore soft databases

2. Restore the database from the last available backup

3. Run ‘Eseutil’ with the ‘/ p’ switch to restore the database. But make sure to back up the database before running this command. This prevents data loss.

4. Use a third-party EDB Recovery Tool to repair and repair the damaged Exchange database

EDB recovery software are exclusive tools built to safely and effectively scan and repair the damaged EDB database file. One of the best utilities is Stellar Phoenix Mailbox Exchange Recovery software with deleted mailbox recovery option, this EDB Recovery Tool supports MS Exchange Server 2007, 2003, 2000 and 5.5 and can extract individual mailboxes as * .pst files.



Source by Axel Culver